We are experiencing problems with the HR-plus client via Citrix
Incident Report for HRplus Production
Resolved
The issue impacting Citrix is now resolved and customers should experience normal functionality at this moment.
Posted Jan 16, 2025 - 10:03 CET
Monitoring
We have applied mitigations affecting user login and launch. We are seeing recovery for impacted users and continuing to monitor.
Posted Jan 16, 2025 - 09:33 CET
Identified
We have identified the cause of the problem affecting user login and launch. We are applying a mitigation and seeing improvement for some users.
Posted Jan 16, 2025 - 09:17 CET
Investigating
We are investigating alerts indicating problems with users logging into Citrix or launching applications. We will provide further updates.
Posted Jan 16, 2025 - 08:54 CET
This incident affected: Production HR-plus 8 Client - Citrix and Stage HR-plus 8 Client - Citrix.