Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 18, 2025 - 10:00 CET
Scheduled
Due to faulty maintenance patch we need to reboot the system. We are experiencing issues with an installed maintenance patch that unfortunately is causing reduced performance in the system. This means we need to restart the HR+ stage environment.
Posted Mar 18, 2025 - 09:20 CET
This scheduled maintenance affected: Stage HR-plus 8 Web and Stage HR-plus 8 Client - Citrix.