Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 07, 2024 - 08:00 CET
Scheduled
On Saturday 7/12 we will have maintenance on HR-plus 8 in our AWS environment. It will affect both the Production and the Stage environment. The service is estimated to be up and running again at latest 12:00. We will inform on the status page when everything is up and running again.
Posted Dec 04, 2024 - 14:28 CET
This scheduled maintenance affected: Production HR-plus 8 Web, Production HR-plus 8 Client - Citrix, Stage HR-plus 8 Web, and Stage HR-plus 8 Client - Citrix.