Citrix client is currently not working
Incident Report for HRplus Production
Resolved
This incident has been resolved.
Posted Mar 03, 2024 - 21:07 CET
Investigating
We are investigating a problem with starting the HR-plus client in Citrix
Posted Mar 03, 2024 - 12:33 CET
This incident affected: Production HR-plus 8 Client - Citrix and Stage HR-plus 8 Client - Citrix.