We are experiencing problems with the HR-plus client via Citrix
Incident Report for HRplus Production
Resolved
The issue impacting Citrix services is now resolved and customers should experience normal functionality at this moment.
Posted Feb 06, 2023 - 12:23 CET
Monitoring
Engineering team have taken mitigation actions to resolve this issue. Users should be seeing improvements.
Posted Feb 06, 2023 - 11:36 CET
Investigating
Citrix Platform is currently experiencing issues. Users may be unable to login.
Posted Feb 06, 2023 - 09:37 CET
This incident affected: Production HR-plus 8 Client - Citrix and Stage HR-plus 8 Client - Citrix.