We are experiencing problems with the HR-plus client via Citrix

Incident Report for HRplus Production

Resolved

This incident has been resolved.
Posted Mar 21, 2023 - 13:35 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2023 - 09:21 CET

Investigating

We are experiencing problems with the HR-plus client via Citrix
Posted Mar 21, 2023 - 09:03 CET
This incident affected: Production HR-plus 8 Client - Citrix and Stage HR-plus 8 Client - Citrix.