We are experiencing problems with the HR-plus client via Citrix

Incident Report for HRplus Production

Resolved

The issue impacting Citrix is now resolved and customers should experience normal functionality at this moment.
Posted Mar 17, 2025 - 09:29 CET

Monitoring

We have applied fixes affecting user login and launch. We are seeing recovery for impacted users and continuing to monitor.
Posted Mar 17, 2025 - 08:43 CET

Identified

We have identified the root cause of the problem affecting user login and launch. We are implementing a fix and are seeing improvement for some users.
Posted Mar 17, 2025 - 08:19 CET

Investigating

We are investigating alerts indicating problems with users logging into Citrix or launching applications. We will provide further updates.
Posted Mar 17, 2025 - 07:58 CET
This incident affected: Production HR-plus 8 Client - Citrix and Stage HR-plus 8 Client - Citrix.